Commit 4a99fe56 authored by Andrey Kleshchev's avatar Andrey Kleshchev
Browse files

SL-14914 New release viewer install updated to RC unexpectedly

Requested behavior: First install of a new viewer should never prompt to update to any RC.
Anfortunately neither viewer nor updater can tell the difference betwen RC and optional release update, so setting updater to download only required updates.
parent 18323f01
......@@ -1172,7 +1172,16 @@ bool LLAppViewer::init()
// add LEAP mode command-line argument to whichever of these we selected
updater.args.add("leap");
// UpdaterServiceSettings
updater.args.add(stringize(gSavedSettings.getU32("UpdaterServiceSetting")));
if (gSavedSettings.getBOOL("FirstLoginThisInstall"))
{
// Befor first login, treat this as 'manual' updates,
// updater won't install anything, but required updates
updater.args.add("0");
}
else
{
updater.args.add(stringize(gSavedSettings.getU32("UpdaterServiceSetting")));
}
// channel
updater.args.add(LLVersionInfo::instance().getChannel());
// testok
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment